Start a new topic

SMTP Settings Test

 Hi,


I am having trouble when adding SMTP settings to Email System. I have tried with Amazon SES with which I have verified, email, domain, added DKIM, TXT record and everything that was needed to be verified. I have tested with all ports and encryption and always get a connection failed message. I am using hosgator and have arpreach installed. I contacted Hostgator and they assured me that ports 25, 465, and 587 were open as these are the default emailing ports.


I have tried the same with SendGrid and entered the necessary details and get the same results. I did run a test email from Actions and received an email. I tried an optin, but email was not sent as there is no emailer.


Please advise.


Thanks


Robby


4 people have this question

Robby I had problems too until I ensured ALL email addresses and domains recorded in ARPR were verified with all those DNS records, etc.

Then I tried changing the port number I was using in ARPR and voila! All OK.

N.B.  In my case, Hostgator told me they allowed those port numbers through the firewall.  Didn't say they were standard...? maybe we have different packages.

Hope this is helpful...!

 

I'm using Bluehost and just discovered they block ALL outgoing SMTP connections. So I will have to switch hosts if I want to use SMTP. Sendmail is working fine though.

Check with your host's port settings.

 

I had exactly the same problem.


I checked my port 465. It was locked down by my firewall.

So I had my host sys admin open it up.


The Amazon DKIM and SPF records were added  2 days ago.

And the SPF record is showing up in Amazon SES dashboard as

"verification pending". But that won't stop your ArpReach app from

connecting to Amazon SES server.


In the end here's what worked for connecting the servers...

Add ssl:// in front of the Amazon email host address - like so:


ssl://email-smtp.us-east-1.amazonaws.com


You'd think something like that would be documented properly. Heh, oh well.

Hey Wynne - I did NOT use that ssl thing and arpR worked fine for me first time. However, Digital Access Pass membership software would not send until I added that extra ssl bit. So maybe the requirement is set elsewhere than arpR? I also notice DAP's notes say Amazon SES is case-sensitive in recognition of verified domains and addresses so wonder if it's worth checking that too? Incidentally, I just discovered it is technically against Hostgator's ToS to use external SMTP. It didn't stop them allowing the ports for me, though, when I explained what I was trying to achieve. But don't want to get in their bad books at all so reconsidering currently. I tried sendgrid also, which was remarkable easy to set up and deliverability looked good.

I'm having this same issue. 


And also getting the connection failed message when trying to set the incoming email settings. And my settings are absolutely 100% the correct settings of my server.


Been fiddling with this for hours. 

I took a walk, had a meal, came back and looked at it with refreshed eyes and was able to get it setup. 


Needed the ss:// added along with other things. 

Login or Signup to post a comment